problem with highlighter and asm

May 4, 2011 at 6:41 PM

I'm using VS 2008 and AsmHighlighter version 1.3 on Windows 7 (32bit).

I have a C program that calls a masm module.

After adding the asm file to the project and clicking on it in the Solution Explorer - up popped my Hex Workshop app.

So closed Hex Workshop, right clicked on the asm module, Open With=> Source Code (Text) Editor With Encoding and

set it as "default".  However the syntax highlighting never kicks in and every time I double-click the asm module in

Solution Explorer (to navigate between opened source files), I get a "document is already opened" dialog.

So I'm guessing I hosed up some file associations.

Any suggestion?

May 7, 2011 at 9:24 AM

Files with extensions .asm .inc .cod should open with the syntax highlighting by default.

If it's not working, It's more likely that you have misconfigured file associations. Go to menu Tools/Options/Text Editor/File Extension. On the right, you shouldn't have any of the asm/inc/code extensions associated with an editor. If there is an association, you have to remove it.

May 10, 2011 at 2:26 PM

Awesome.  Works great now. Thanks for the directions!